Service management software News

Blog

Solarvista LIVE Mobile Minimum Android Version

To make sure that we are able to provide the latest features to our customers we are making some changes to the miminum version of Android that is required for Solarvista LIVE Mobile. As of the 1st of July 2017, the minimum version of Android required is 4.4 (KitKat).

Read More

Solarvista LIVE Mobile 6.2.1 Release Notes


Version 6.2.1 of Solarvista LIVE Mobile is now available. Like version 6.1 it contains minor updates to the UI, but in addition we have made many changes to make the app more robust and perform better on all platforms.

Read More